ECMAScript
6(以下简称ES6)是JavaScript语言的下一代标准,已经在2015年6月正式发布了。它的目标,是使得JavaScript语言可以用来编写复杂的大型应用程序,成为企业级开发语言。

1前言

该系列文章均为学习阮一峰老师《ECMAScript
6 入门》一书的学习笔记。原著:

各大浏览器的最新版本,对ES6的支持可以查看kangax.github.io/es5-compat-table/es6/。随着时间的推移,支持度已经越来越高了,ES6的大部分特性都实现了。

Node.js是JavaScript语言的服务器运行环境,对ES6的支持度比浏览器更高。通过Node,可以体验更多ES6的特性。建议使用版本管理工具nvm,来安装Node,因为可以自由切换版本。不过,
nvm不支持Windows系统,如果你使用Windows系统,下面的操作可以改用nvmw或nvm-windows代替。

Babel是一个广泛使用的转码器,可以将ES6代码转为ES5代码,从而在现有环境执行。

学习ES6之前,我们可以先来看一下各大浏览器的最新版本对ES6的支持,点击这里

2安装Babel

由于目前很多浏览器对ECMAScript
6的支持度有限,但是又想使用ECMAScript
6提供的高级语法,因此babel诞生了,它能将ECMAScript
6的特殊语法转换为ECMAScript
5中对应的解决方案,所以我们不用等到浏览器的支持就可以在项目中使用ES6的特性。。

babel6之后,将babel拆分成两个包:babel-cli和babel-core。如果你想要在CLI(终端或REPL)使用babel就下载babel-cli,如果想要在node中使用就下载babel-core。

一般情况下,我们不会将babel安装在全局,因为不同的项目可能使用不同的babel,并且安装在全局,那么我们的项目就对环境产生了依赖,因此,通常我们将babel-cli安装在项目中。

图片 1

我们可以使用以下几种环境去学习ES6

2.1. 创建一个学习项目

图片 2

js_ES5用来存放转换后的ECMAScript
5文件,js_ES6用来存放ECMAScript 6文件文件。

要想在这个项目中使用npm命令安装babel等,必须首先建立package.json文件,为此使用

图片 3图片 4

1 npm init

View Code

命令在项目中引导创建一个package.json文件。

图片 5

这意味着,你可以现在就用ES6编写程序,而不用担心现有环境是否支持。下面是一个例子。

使用最新版本的Chrome或者Chromium

来说一下在Ubuntu下,如何升级到最新的Chromium,需要执行如下命令即可。

sudo add-apt-repository ppa:chromium-daily 
sudo apt-get update 
sudo apt-get install chromium-browser

然后需要开启对ES6的支持,访问chrome://flags/#enable-javascript-harmony页面,开启这个特性。

然后你就可以在Chromium的console中使用ES6了。

2.2. 安装babel-cli

npm install --save-dev babel-cli

图片 6

// 转码前
input.map(item => item + 1);

// 转码后
input.map(function (item) {
return item + 1;
});

使用Node.js

建议更新到Node的最新版本,或者最新的稳定版本,这样Node对ES6的支持可能会多一些。

升级Node可以使用nvm或者n等版本管理工具。

我使用的是n,命令入下:

// 全局安装n
sudo npm install -g n
// 安装制定版本
n 5.6.0
// 安装最新的版本
n latest
// 安装稳定版本
n stable
// 删除某个版本
n rm 5.6.0
// 以指定的版本来执行脚本
n use 5.6.0 some.js

我安装了稳定版本,当前是5.6.0

可以使用如下命令查看当前版本的Node对ES6的支持

node --v8-options | grep harmony

使用的时候只需要带上–harmony参数

node --harmony
node --harmony test.js

2.3. 安装 babel-preset-es2015

npm install --save-dev babel-preset-es2015

图片 7

babel-preset-es2015是Babel官方提供的一个转码规则,还有其他的转码规则:

# ES2015转码规则
$ npm install --save-dev babel-preset-es2015

# react转码规则
$ npm install --save-dev babel-preset-react

# ES7不同阶段语法提案的转码规则(共有4个阶段),选装一个
$ npm install --save-dev babel-preset-stage-0
$ npm install --save-dev babel-preset-stage-1
$ npm install --save-dev babel-preset-stage-2
$ npm install --save-dev babel-preset-stage-3

上面的原始代码用了箭头函数,这个特性还没有得到广泛支持,Babel将其转为普通函数,就能在现有的JavaScript环境执行了。

使用Babel

Babel是一个广泛使用的ES6转码器,可以将ES6代码转为ES5代码,从而在现有环境执行。这意味着,你可以用ES6的方式编写程序,又不用担心现有环境是否支持。

如何安装Babel我就简单举一个例子。以一个test项目为例。

先创建test文件夹,然后在该文件夹下执行npm
init,初始化package.json文件,然后修改为如下的内容:

{
  "name": "test",
  "version": "1.0.0",
  "description": "A babel test project",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "build": "babel src -d lib"
  },
  "author": "HarrySun",
  "license": "MIT",
  "devDependencies": {
    "babel-cli": "^6.6.4",
    "babel-preset-es2015": "^6.6.0"
  }
}

其中scripts中的build命令,是指将src下的文件夹里的es6的js文件转化成es5的js文件。

然后执行一下npm install,安装babel-cli和babel-preset-es2015包。

最后创建一下.babelrc配置文件,命令如下:

echo '{ "presets": ["es2015"] }' > .babelrc

这个项目的例子,请点击这里

给一个官网地址,大家可以根据不同的环境就自己的需求选择。Babel
Setup

2.4.配置babel

Babel的配置文件是.babelrc,存放在项目的根目录下。使用Babel的第一步,就是配置这个文件。该文件用来设置转码规则和插件,基本格式如下。

{
  "presets": [],
  "plugins": []
}

presets字段设定转码规则。但是在windows系统中,不允许直接右键建立没有文件名的文件,可以通过cmd命令行创建:在当前文件夹打开cmd并键入命令

图片 8

这样我们就创建了一份babel的配置文件,配置它:

图片 9

一、配置文件.babelrc

Babel的配置文件是.babelrc,存放在项目的根目录下。使用Babel的第一步,就是配置这个文件。

该文件用来设置转码规则和插件,基本格式如下。

{
“presets”: [],
“plugins”: []
}

presets字段设定转码规则,官方提供以下的规则集,你可以根据需要安装。

# ES2015转码规则
$ npm install --save-dev babel-preset-es2015

# react转码规则
$ npm install --save-dev babel-preset-react

# ES7不同阶段语法提案的转码规则(共有4个阶段),选装一个
$ npm install --save-dev babel-preset-stage-0
$ npm install --save-dev babel-preset-stage-1
$ npm install --save-dev babel-preset-stage-2
$ npm install --save-dev babel-preset-stage-3

然后,将这些规则加入.babelrc

{
“presets”: [
“es2015”,
“react”,
“stage-2”
],
“plugins”: []
}

注意,以下所有Babel工具和模块的使用,都必须先写好.babelrc

2.5. 修改package.json

图片 10

build 的值的规范为:

$babel es6.js #转换代码直接输出
$babel es6.js -o es5.js #转换代码输出到文件
$babel -d build-dir source-dir #转换整个目录
$babel -d build-dir source-dir -s #转换整个目录,并生成 source map
映射文件

二、命令行转码babel-cli

Babel提供babel-cli工具,用于命令行转码。

它的安装命令如下。

$ npm install –global babel-cli

基本用法如下。

# 转码结果输出到标准输出
$ babel example.js

# 转码结果写入一个文件
# --out-file 或 -o 参数指定输出文件
$ babel example.js --out-file compiled.js
# 或者
$ babel example.js -o compiled.js

# 整个目录转码
# --out-dir 或 -d 参数指定输出目录
$ babel src --out-dir lib
# 或者
$ babel src -d lib

# -s 参数生成source map文件
$ babel src -d lib -s

上面代码是在全局环境下,进行Babel转码。这意味着,如果项目要运行,全局环境必须有Babel,也就是说项目产生了对环境的依赖。另一方面,这样做也无法支持不同项目使用不同版本的Babel。

一个解决办法是将babel-cli安装在项目之中。

# 安装
$ npm install --save-dev babel-cli

然后,改写package.json

{
// …
“devDependencies”: {
“babel-cli”: “^6.0.0”
},
“scripts”: {
“build”: “babel src -d lib”
},
}

转码的时候,就执行下面的命令。

$ npm run build

2.6. 执行转码:

图片 11

这时在js_ES5的目录下,就有转码后的文件里了

图片 12

三、babel-node

babel-cli工具自带一个babel-node命令,提供一个支持ES6的REPL环境。它支持Node的REPL环境的所有功能,而且可以直接运行ES6代码。

它不用单独安装,而是随babel-cli一起安装。然后,执行babel-node就进入PEPL环境。

$ babel-node

> (x => x * 2)(1)
2

babel-node命令可以直接运行ES6脚本。将上面的代码放入脚本文件es6.js,然后直接运行。

$ babel-node es6.js
2

babel-node也可以安装在项目中。

$ npm install –save-dev babel-cli

然后,改写package.json

{
“scripts”: {
“script-name”: “babel-node script.js”
}
}

上面代码中,使用babel-node替代node,这样script.js本身就不用做任何转码处理。

3 安装babel-register

babel-register模块改写require命令,为它加上一个钩子。此后,每当使用require加载.js.jsx.es.es6后缀名的文件,就会先用Babel进行转码。

npm install --save-dev babel-register

图片 13

使用时,必须首先加载babel-register

require("babel-register");
require("es6");

然后,就不需要手动对es6.js转码了。

图片 14需要注意的是,babel-register只会对require命令加载的文件转码,而不会对当前文件转码。另外,由于它是实时转码,所以只适合在开发环境使用

四、babel-register

babel-register模块改写require命令,为它加上一个钩子。此后,每当使用require加载.js.jsx.es.es6后缀名的文件,就会先用Babel进行转码。

$ npm install –save-dev babel-register

使用时,必须首先加载babel-register

require(“babel-register”);
require(“./index.js”);

然后,就不需要手动对index.js转码了。

需要注意的是,babel-register只会对require命令加载的文件转码,而不会对当前文件转码。另外,由于它是实时转码,所以只适合在开发环境使用。

4安装babel-polyfill

Babel默认只转换新的JavaScript句法(syntax),而不转换新的API,比如Iterator、Generator、Set、Maps、Proxy、Reflect、Symbol、Promise等全局对象,以及一些定义在全局对象上的方法(比如Object.assign)都不会转码。

举例来说,ES6在Array对象上新增了Array.from方法。Babel就不会转码这个方法。如果想让这个方法运行,必须使用babel-polyfill,为当前环境提供一个垫片。

安装命令如下。

npm install --save babel-polyfill

然后,在脚本头部,加入如下一行代码。

require("babel-polyfill");

Babel默认不转码的API非常多,详细清单可以查看babel-plugin-transform-runtime模块的definitions.js文件。

require ("babel-polyfill");
[1,2,3].map(n => n + 1);
function addAll() {
    return Array.from(arguments).reduce((a, b) => a + b);
}

执行npm run build转码后:

"use strict";

var _from = require("babel-runtime/core-js/array/from");

var _from2 = _interopRequireDefault(_from);

function _interopRequireDefault(obj) { return obj && obj.__esModule ? obj : { default: obj }; }

require("babel-polyfill");
[1, 2, 3].map(function (n) {
    return n + 1;
});
function addAll() {
    return (0, _from2.default)(arguments).reduce(function (a, b) {
        return a + b;
    });
}

 

五、babel-core

如果某些代码需要调用Babel的API进行转码,就要使用babel-core模块。

安装命令如下。

$ npm install babel-core –save

然后,在项目中就可以调用babel-core

var babel = require(‘babel-core’);

// 字符串转码
babel.transform(‘code();’, options);
// => { code, map, ast }

// 文件转码(异步)
babel.transformFile(‘filename.js’, options, function(err, result) {
result; // => { code, map, ast }
});

// 文件转码(同步)
babel.transformFileSync(‘filename.js’, options);
// => { code, map, ast }

// Babel AST转码
babel.transformFromAst(ast, code, options);
// => { code, map, ast }

配置对象options,可以参看官方文档。

下面是一个例子。

var es6Code = ‘let x = n => n + 1’;
var es5Code = require(‘babel-core’)
.transform(es6Code, {
presets: [‘es2015’]
})
.code;
// ‘”use strict”;\n\nvar x = function x(n) {\n return n + 1;\n};’

上面代码中,transform方法的第一个参数是一个字符串,表示需要转换的ES6代码,第二个参数是转换的配置对象。

5Babel常用命令

1、转换es6.js文件并在当前命名行程序窗口中输出

babel es6.js

2、将es6.js转换后输出到es5.js文件中(使用 -o 或 –out-file )

babel es6.js -o es5.js 
babel es6.js --out-file es5.js

3、实时监控es6.js一有变化就重新编译(使用 -w 或 –watch )

babel es6.js -w --out-file es5.js
babel es6.js --watch --out-file es5.js

4、编译整个src文件夹并输出到lib文件夹中(使用 -d 或 –out-dir )

babel src -d lib
babel src --out-dir lib

5、编译整个src文件夹并输出到一个文件中

babel src --out-file es5.js

6、直接输入babel-node命令,可以在命令行中直接运行ES6代码

babel-node

六、babel-polyfill

Babel默认只转换新的JavaScript句法(syntax),而不转换新的API,比如Iterator、Generator、Set、Maps、Proxy、Reflect、Symbol、Promise等全局对象,以及一些定义在全局对象上的方法(比如Object.assign)都不会转码。

举例来说,ES6在Array对象上新增了Array.from方法。Babel就不会转码这个方法。如果想让这个方法运行,必须使用babel-polyfill,为当前环境提供一个垫片。

安装命令如下。

$ npm install –save babel-polyfill

然后,在脚本头部,加入如下一行代码。

import ‘babel-polyfill’;
// 或者
require(‘babel-polyfill’);

Babel默认不转码的API非常多,详细清单可以查看babel-plugin-transform-runtime模块的definitions.js文件。

七、浏览器环境

Babel也可以用于浏览器环境。但是,从Babel
6.0开始,不再直接提供浏览器版本,而是要用构建工具构建出来。如果你没有或不想使用构建工具,可以通过安装5.x版本的babel-core模块获取。

$ npm install babel-core@5

运行上面的命令以后,就可以在当前目录的node_modules/babel-core/子目录里面,找到babel的浏览器版本browser.js(未精简)和browser.min.js(已精简)。

然后,将下面的代码插入网页。


上面代码中,browser.js是Babel提供的转换器脚本,可以在浏览器运行。用户的ES6脚本放在script标签之中,但是要注明type="text/babel"

另一种方法是使用babel-standalone模块提供的浏览器版本,将其插入网页。


注意,网页中实时将ES6代码转为ES5,对性能会有影响。生产环境需要加载已经转码完成的脚本。

下面是如何将代码打包成浏览器可以使用的脚本,以Babel配合Browserify为例。首先,安装babelify模块。

$ npm install –save-dev babelify babel-preset-es2015

然后,再用命令行转换ES6脚本。

$ browserify script.js -o bundle.js \
-t [ babelify –presets [ es2015 react ] ]

上面代码将ES6脚本script.js,转为bundle.js,浏览器直接加载后者就可以了。

package.json设置下面的代码,就不用每次命令行都输入参数了。

{
“browserify”: {
“transform”: [[“babelify”, { “presets”: [“es2015”] }]]
}
}

八、在线转换

Babel提供一个REPL在线编译器,可以在线将ES6代码转为ES5代码。转换后的代码,可以直接作为ES5代码插入网页运行。

九、与其他工具的配合

许多工具需要Babel进行前置转码,这里举两个例子:ESLint和Mocha。

ESLint 用于静态检查代码的语法和风格,安装命令如下。

$ npm install –save-dev eslint babel-eslint

然后,在项目根目录下,新建一个配置文件.eslint,在其中加入parser字段。

{
“parser”: “babel-eslint”,
“rules”: {

}
}

再在package.json之中,加入相应的scripts脚本。

{
“name”: “my-module”,
“scripts”: {
“lint”: “eslint my-files.js”
},
“devDependencies”: {
“babel-eslint”: “…”,
“eslint”: “…”
}
}

Mocha 则是一个测试框架,如果需要执行使用ES6语法的测试脚本,可以修改package.jsonscripts.test

“scripts”: {
“test”: “mocha –ui qunit –compilers js:babel-core/register”
}

上面命令中,--compilers参数指定脚本的转码器,规定后缀名为js的文件,都需要使用babel-core/register先转码。

(完)

本文转自
526955818**

相关文章